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Problem

You aren't receiving mail from one of the Mailing Lists on campus.

Cause

There are a few possible reasons this is happening...

  1. You are the sender of the message to the Mailing List
  2. The message is probably treated as spam
  3. Your UCSB Connect Account does not have the mailing alias that was subscribed to the mailing list
  4. You clicked unsubscribe or digest at one point
  5. Google is deliberately rate limiting you (especially if mail is not completely missing, but wandering in a day or two after it was sent)

Solution

1. You are the sender of the message to the Mailing List

Unfortunately, in the efforts to reduce duplication of messages, UCSB Connect (aka GMail) will not have a copy of the message in your Inbox, as it already exists in your Sent Folder.

There is no real easy way to prevent this functionality short of adding yourself, manually, to the CC.

2. The message is probably treated as spam

You may want to check in your Spam folder to see if it is there.

Sometimes the message may get treated as spam due to the content in the message.

If it is there, you can click on the message and then on the Not Spam above the message or Report As Not Spam.

3. Your UCSB Connect Account does not have the mailing alias that was subscribed to the mailing list

Some of the Engineering Accounts may not have been merged to the @engineering.ucsb.edu domain.

As an example:

User jdoe is part of Mechanical Engineering prior to the UCSB Connect merge and always used jdoe@engineering.ucsb.edu email address.

After the merge, jdoe was given the UCSB Connect account of jdoe@ucsb.edu, and jdoe@me.ucsb.edu, but not jdoe@engineering.ucsb.edu.

To see what aliases are associated with your UCSB Connect account, do the following:

  1. Go to the UCSB Connect Web Mail App
  2. Login with your UCSB Connect Account
  3. Click on the gear icon () in the right hand corner and then click on Settings
  4. From there, click on Accounts
  5. Under the Send mail as section, you should see the mailing addresses that is associated with your UCSB Connect Account.

If you do not see the <your username>@engineering.ucsb.edu listed, you can contact help@engineering.ucsb.edu to add that alias.

Otherwise, you can also just re-subscribe to the mailing list or contact the Mailing List admin to update the list with your current, preferred email address.

4. You clicked unsubscribe or digest at one point

Many mailing lists and google groups offer the option to unsubscribe, if you clicked this, please contact the list or group owner to be added back.

Many mailing lists and google groups also offer a digest option, which means you get emailed once a day/week/month in a batch instead of every time an email goes out. To fix this for google groups:

  1. Go to the UCSB Connect Web Mail App
  2. Login with your UCSB Connect Account
  3. Go to the box of nine boxes at the top
  4. Click the option that says Groups
  5. Go to the group you are not getting mail from
  6. Go to the My Membership Settings tab
  7. You can then alter your mail preferences
5. Google is deliberately rate limiting you

UCSB uses Google Connect for most individual emails, which means a lot of delays are not actually from the Mailman servers but at the point where Google accepts mail from said server or delivers said mail to individuals.

Due to the abuse of third party apps by spammers across the planet, Google is deliberately being heavy handed in an effort to encourage people to use google groups or pay extra to use mass mail options.

  1. Maximum number of posts a member can make to a group before completing CAPTCHA verification: 100 per day
  2. Maximum number of posts a member can make to a group after completing CAPTCHA verification: 500 per day (includes 100 prior to verification)
    1. This means if you are emailing a google group with 100 members, you can only send 5 emails to this group per day, any more than that will be held for 24 hours till your timer resets
    2. This also means even with Google verification on our Mailman servers, a single mailman list is rate limited assuming everyone you are emailing is using their UCSB school emails. e.g. 1 email to 500 people per day, 5 emails to 100 people, etc... It is often better to send 1 larger email than multiple smaller emails if you are concerned about people getting their mail in a timely manner.
  3. Total message size: 2.4 GB per hour (meaning if you are sending max size 25 Mb emails full of pictures/posters, only 96 emails will go out per hour)
  4. Google reserves the right to rate limit and blacklist servers with "excessive bounces", "spam looking content", etc... 
    1. meaning for example if you have a Mailman list of 100 members and 4 of them are bouncing, after the third bounce, google will stop accepting mail from said Mailman list for a time, so the members who were at the front of the list may get their mail in minutes and the people at the end of the list after the third bounce may get their mail after a day delay.
    2. Google is vague on what goes into their spam score but in general, large pictures with embedded HTML links, signatures with URLs, and shortened URLs that redirect somewhere else all raise your spam score.

Due to the above issues we are encouraging the following:

  1. Conversion of Mailman lists to Google groups: that way we are only dealing with delays internal to the Google Connect system
  2. Limiting Google groups to 100 people or less and using Google groups made of smaller Google groups.
    1. A message to a Google group of 1000 people may take up to 2 days to reach everyone (500 emails per day times 2 days = 1000 emails)
    2. A message to a google group of 10 google groups each of 100 people will go out in minutes and you can send up to 5 emails per day to this group of groups before the smaller groups of 100 people stop accepting mail.
    3. Smaller lists are easier to manage, allow for more messages per day to be sent, and allows for segmentation. e.g. you can have separate Google groups for say undergraduates and graduate students.



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