Problem
You aren't receiving mail from one of the Mailing Lists on campus.
Cause
There are a few possible reasons this is happening...
- You are the sender of the message to the Mailing List
- The message is probably treated as spam
- Your UCSB Connect Account does not have the mailing alias that was subscribed to the mailing list
Solution
Unfortunately, in the efforts to reduce duplication of messages, UCSB Connect (aka GMail) will not have a copy of the message in your Inbox, as it already exists in your Sent Folder.
There is no real easy way to prevent this functionality short of adding yourself, manually, to the CC.
You may want to check in your Spam folder to see if it is there.
Sometimes the message may get treated as spam due to the content in the message.
If it is there, you can click on the message and then on the Not Spam above the message or Report As Not Spam.
Some of the Engineering Accounts may not have been merged to the @engineering.ucsb.edu domain.
As an example:
User jdoe is part of Mechanical Engineering prior to the UCSB Connect merge and always used jdoe@engineering.ucsb.edu email address.
After the merge, jdoe was given the UCSB Connect account of jdoe@ucsb.edu, and jdoe@me.ucsb.edu, but not jdoe@engineering.ucsb.edu.
To see what aliases are associated with your UCSB Connect account, do the following:
- Go to the UCSB Connect Web Mail App
- Login with your UCSB Connect Account
- Click on the gear icon () in the right hand corner and then click on Settings
- From there, click on Accounts
- Under the Send mail as section, you should see the mailing addresses that is associated with your UCSB Connect Account.
If you do not see the <your username>@engineering.ucsb.edu listed, you can contact help@engineering.ucsb.edu to add that alias.
Otherwise, you can also just re-subscribe to the mailing list or contact the Mailing List admin to update the list with your current, preferred email address.
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