I'm sent a Box invite to a folder, but it isn't showing up on my Box account.

Problem

Someone sent you a share invite to their Box, and when you accept it, it does not show on your Box account.

Cause

The most likely culprit is that the invite was sent to your departmental email account and not to your @ucsb.edu account.

Your @ucsb.edu account would be:

<UCSBNetID>@ucsb.edu

Solution

Ask the inviter to resend the invite to your @ucsb.edu account, giving them the email as:

<UCSBNetID>@ucsb.edu

Your current mail should be receiving the invite.

While both your COE and Campus emails are accessed through UCSB connect, your COE account is not the same as your UCSBnetID for authentication purposes. Depending on how it was set up, your COE accounts can have completely different credentials from your UCSBnetID. When using campus level resources, it is best to use your campus level credentials. When using departmental level resources, it is best to use your departmental level credentials.