Unable to create a CSIL/Engineering Account

Problem

You are trying to create your CSIL/Account using your UCSBNetID but you get a message saying:

Your UCSBNetID is not authorized for an account.

Cause

  1. You just recent added the course - Our account provisioning system has not caught up with the registrar system with regards to the change.
  2. You are an Extension Student - Our account provisioning system does not receive information with regards to Extension Students at this time.
  3. You are crashing the course - Just like adding the course, the system has no means to know you are in the course or not.
  4. You already have an College of Engineering Account - also known as CoE, ECI, CSIL, CS, among other names.

Solution

Here are your only options at this time

  1. Recently added the course - Please give the system 1 business day to catch up, then try again.
  2. Extension Students - You will need to contact help@engineering.ucsb.edu. You will be provided an extension account that will be usable for a short period of time.
  3. Crashing the Course - At this time, we can only provide accounts upon proof of enrollment with the course.
  4. Already have a College of Engineering Account - This only happens if you took a College of Engineering course or tried to crash one in the past. You can try and see if it is still around by going to https://accounts.engr.ucsb.edu/maintain and try logging in there, or contact help@engineering.ucsb.edu if you forgot what your username is. In general if you have an username@engineering.ucsb.edu email alias, you must likely have a CoE account with said username.